Weaken WordPress passwords

WordPress requires strong passwords for administrators, authors, and editors, and requires at least moderately complex passwords for everyone else. If you want to weaken your WordPress password policy so that anything can be accepted, all you have to do is include this code snippet in a plugin or theme.
add_action( 'wp_print_scripts', function() {
    if ( wp_script_is( 'wc-password-strength-meter', 'enqueued' ) ) {
        wp_dequeue_script( 'wc-password-strength-meter' );
    }
}, 100 );
Note that this is probably an incredibly bad idea, but I run into a client once in a while that insists on having simpler passwords. This totally nukes all password complexity requirements.

Leave a Reply

Your email address will not be published. Required fields are marked *